导入Android项目后Eclipse报错

  次阅读 作者:智能小宝 来源:互联网 2016-01-14 14:14 我要评论(0)

报错如下:

Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools

如果遇到上述问题,没关系,很容易就解决了。其实就是项目使用的编译环境不对,因为jdk有1.5,1.6,1.7等,它需要5或6,你却给它的是7,所以编译器就抱怨了。

两个选择:

右键单击你的项目,并且选择"Android Tools -> Fix Project Properties" ,如果这个没有,看第二个。

右键单击你的项目,选择"Properties,然后在对话框中选择“ Java Compiler",检查"Enable project specific settings" 选项,并且从"Compiler compliance settings"选择1.5 or 1.6 。

ok了。

本站文章信息来源于网络以及网友投稿,本站只负责对文章进行整理、排版、编辑,是出于传递更多信息之目的,并不意味着赞同其观点或证实其内容的真实性。如果您有什么意见或建议,请联系QQ28-1688-302!

人工智能实验室
相关文章相关文章
  • 韩春雨称已能重复实验结果 近期将有消息公布

    韩春雨称已能重复实验结果 近期将有消息公布

  • 英国研发“杀生”机器人 通过生命体获取能量

    英国研发“杀生”机器人 通过生命体获取能量

  • 未来两年人工智能要怎么走?看这篇就够了

    未来两年人工智能要怎么走?看这篇就够了

  • 无人驾驶汽车如何改变城市生活?听听他们怎么说

    无人驾驶汽车如何改变城市生活?听听他们怎么说

网友点评网友点评
阅读推荐阅读推荐

据国外媒体报道,在过去两年内,聊天机器人(chatbot)、人工智能以及机器学习的研发和采用取得了巨大进展。许多初创公司正利用人工智能和...

霍金 视觉中国 图 英国著名物理学家霍金(Stephen Hawking)再次就人工智能(AI)发声,他认为:对于人类来说,强大AI的出现可能是最美妙的...

文|郑娟娟 今年,人工智能(AI) 60岁了。在AI60岁的时候,笔者想要介绍一下AI100,一个刚刚2岁的研究项目,但它的预设寿命是100年,甚至更长...

AlphaGo与李世石的人机大战,为大众迅速普及了人工智能的概念。 但对谷歌而言,除了下围棋,现在的人工智能进展到哪一步了?未来,人工智能...