Android源码编译过程详细步骤

  次阅读 作者:智能小宝 来源:互联网 2016-01-19 11:30 我要评论(0)

Android编译主要包括对C,C++,的编译,这里主要是GCC,G++,编译器,针对ARM平台的编译器,主要是arm-eabi-编译器, 还有针对JAVA的编译器,就是JDK,对GCC,G++最好的版本是4.3版,ubuntu 8.04的gcc版本是4.2.4,并且通过apt-get install没有gcc4.3的包。

说一下Android源码的编译,这个困扰了我粉久的问题,在网上随便搜一下Android源码编译,都能搜出很多结果,但在这里我得告诉你,别太 乐观,没有一个网页能让你顺顺利利的按照步骤,编译出最后的img的。我在这里尽量把我所遇到的问题、及解决办法告诉大家,我自认编译Android所能 遇到的问题,我都遇到了,所以应该是一个比较全的编译指南,有不对的地方欢迎指教。

首先说一下,编译Android所用的系统,目前ubuntu是比较好的平台,也是官方推荐的,但具体版本,说的都比较少,为了避免大家走弯路,我 这里说一下,最好的就是ubuntu 8.10,他所带有的各个编译器都是最合适的,Android编译对编译器的要求近乎于苛刻。网上总说以8.04作为编译的系统,但我在这里说,8.04 绝不是什么最好的系统。下面我会一一说明。

Android编译主要包括对C,C++,的编译,这里主要是GCC,G++,编译器,针对ARM平台的编译器,主要是arm-eabi-编译器, 还有针对JAVA的编译器,就是JDK,对GCC,G++最好的版本是4.3版,ubuntu 8.04的gcc版本是4.2.4,并且通过apt-get install没有gcc4.3的包,这里郁闷了我很久,最后通过下载8.10的包才完成的GCC升级,顺带说一下,ubuntu apt-get工具的源添加方法,在/etc/apt/sourcelist里面是源的地址,在这里加入8.10版本的升级源,就可以通过apt安装下载 8.10的应用程序了,但由于在8.04下升级不能达到GCC4.3,正常情况下,对不同版本的系统软件升级是不能使用别的版本的软件的,所以这样做不知 道有什么不好的结果,所以选择操作系统最好是8.10,如果是9以后的版本就需要降级,就是安装低版本的程序,通过在/usr/bin下修改软链接、或者 apt-alternatives --config 来选择,对GCC的链接,通过ln -sf gcc-4.3 gcc,修改,对JDK需要通过apt-alternatives --config java,apt-alternatives --config javac,apt-alternatives --config javah,进行修改,选择JDK1.5版本。

首先下载Android的源代码,Android的源代码管理工具是使用git,配合repo来实现的,安装git,curl http://android.git.kernel.org/repo > /home/android /bin/repo,通过repo init -u选择Android代码进行下载,这里在下载时,最好使用-b选择下载的版本,主要因为默认下载的是master branch就是正在编写、升级的版本,说白了属于测试版,对编译Android来说,没什么好处,最好通过-b指定稳定版本进行下载,-b后面可以是 cupcake/eclair等等,这里需要耐心等待,一般下载5,6个钟头就能下载完毕,以我的经历,一般是早上6点钟到上午10点左右速度都很好的, 其他时间速度不行。网络经常断,通过XXXX修改。

接着是编译环境的配置,编译Android需要安装很多软件,apt-get install git-core gnupg sun-java5-jdk flex bison gperf libsdl-dev libesd0-dev libwxgtk2.6-dev build-essential zip curl libncurses5-dev zlib1g-dev,这些是官方说明中需要的,可能还有fakeroot,apt-get install valgrind ,反正这里一定要确保完全安装这些工具,否则编译会出很多莫名其妙的问题。

接着就可以make了,首先检查一下gcc,jdk版本是不是gcc-4.3,JDK1.5版本,接着修正环 境变量,export JAVA_HOME=/yourJDKpath/,ANDROID_JAVA_HOME=$JAVA_HOME,将这两句加入/etc /environment中,重启机器,将环境变量启用。

[android]编译时出现 /usr/include/gnu/stubs.h:7: fatal error: gnu/stubs-32.h: No such file or directory 错误信息

缺少libc开发包,安装即可: apt-get install libc6-dev-i386

[android]编译时出现/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.4.5/../../../libz.so when searching for -lz错误信息

缺少lib32z1-dev,安装即可:apt-get install lib32z1-dev

引自:http://0123.blog.163.com/blog/static/4788312010102392452933/

host Executable: acp (out/host/linux-x86/obj/EXECUTABLES/acp_intermediates/acp)

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.4.3/libstdc++.so when searching for -lstdc++

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.4.3/libstdc++.a when searching for -lstdc++

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.4.3/libstdc++.so when searching for -lstdc++

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.4.3/libstdc++.a when searching for -lstdc++

解决:

sudo apt-get install g++-multilib

GL/glx.h: No such file or directory)

sudo apt-get install libgl1-mesa-dev

本站文章信息来源于网络以及网友投稿,本站只负责对文章进行整理、排版、编辑,是出于传递更多信息之目的,并不意味着赞同其观点或证实其内容的真实性。如果您有什么意见或建议,请联系QQ28-1688-302!

人工智能实验室
相关文章相关文章
  • 无人驾驶汽车如何改变城市生活?听听他们怎么说

    无人驾驶汽车如何改变城市生活?听听他们怎么说

  • 英国研发“杀生”机器人 通过生命体获取能量

    英国研发“杀生”机器人 通过生命体获取能量

  • 未来两年人工智能要怎么走?看这篇就够了

    未来两年人工智能要怎么走?看这篇就够了

  • 韩春雨称已能重复实验结果 近期将有消息公布

    韩春雨称已能重复实验结果 近期将有消息公布

网友点评网友点评
阅读推荐阅读推荐

据国外媒体报道,在过去两年内,聊天机器人(chatbot)、人工智能以及机器学习的研发和采用取得了巨大进展。许多初创公司正利用人工智能和...

霍金 视觉中国 图 英国著名物理学家霍金(Stephen Hawking)再次就人工智能(AI)发声,他认为:对于人类来说,强大AI的出现可能是最美妙的...

文|郑娟娟 今年,人工智能(AI) 60岁了。在AI60岁的时候,笔者想要介绍一下AI100,一个刚刚2岁的研究项目,但它的预设寿命是100年,甚至更长...

AlphaGo与李世石的人机大战,为大众迅速普及了人工智能的概念。 但对谷歌而言,除了下围棋,现在的人工智能进展到哪一步了?未来,人工智能...