Android开发之manifest上遇到的错误

  次阅读 作者:智能小宝 来源:互联网 2016-01-19 12:22 我要评论(0)

最近导入网上的源码工程,发现在manifest上有一些错误,这里也顺便和大家分享下:

一、android:installLocation

这个参数,其实我们一般用不到的,这里解释下:

它是android2.2引入的,注意你的版本android:targetSdkVersion,这个要大于等于8才可以。

关于这个参数的作用:

从android的开发文档来看:

<span style="font-size:12px;"><manifest xmlns:android="http://schemas.android.com/apk/res/android"

package="string"

android:sharedUserId="string"

android:sharedUserLabel="string resource"

android:versionCode="integer"

android:versionName="string"

android:installLocation=["auto" | "internalOnly" | "preferExternal"] >

. . .

</manifest></span>

internalOnly:表示只把当前应用程序安装在内存中,不能安装在SD卡上。如果内存满了,它就不能正常安装了。而且它就是默认值。

auto:表示可以安装在SD卡,默认会安装在手机内存中。如果内存满了,它会选择安装在SD上。

preferExternal:表示程序会安装在SD卡上,如果SD卡不能用,或者满了的话,它也可能会安装在内存中。此外,用户也可以自由切 换安装的位置。

这段简单说来就是,默认情况下,程序会安装在内存中,除非你只记得定义了。

还有就是,即使你安装程序在SD卡上,但应用保存的数据还是会保存在手机内存上。

对于apk程序而言,都有一个随机密钥,它可以确保程序只能由安装它的程序来操作。如果SD卡被卸载了,那么应用程序也就没有了。我们会发现在 拿掉SD卡时,手机上的程序少了很多,就是这个原因造成的。

二、android:xlargeScreens

这个就简单了,这个是android2.3引入的,注意你的版本android:targetSdkVersion,这个要大于等于10才可 以。

本站文章信息来源于网络以及网友投稿,本站只负责对文章进行整理、排版、编辑,是出于传递更多信息之目的,并不意味着赞同其观点或证实其内容的真实性。如果您有什么意见或建议,请联系QQ28-1688-302!

人工智能实验室
相关文章相关文章
  • 英国研发“杀生”机器人 通过生命体获取能量

    英国研发“杀生”机器人 通过生命体获取能量

  • 无人驾驶汽车如何改变城市生活?听听他们怎么说

    无人驾驶汽车如何改变城市生活?听听他们怎么说

  • 未来两年人工智能要怎么走?看这篇就够了

    未来两年人工智能要怎么走?看这篇就够了

  • 韩春雨称已能重复实验结果 近期将有消息公布

    韩春雨称已能重复实验结果 近期将有消息公布

网友点评网友点评
阅读推荐阅读推荐

据国外媒体报道,在过去两年内,聊天机器人(chatbot)、人工智能以及机器学习的研发和采用取得了巨大进展。许多初创公司正利用人工智能和...

霍金 视觉中国 图 英国著名物理学家霍金(Stephen Hawking)再次就人工智能(AI)发声,他认为:对于人类来说,强大AI的出现可能是最美妙的...

文|郑娟娟 今年,人工智能(AI) 60岁了。在AI60岁的时候,笔者想要介绍一下AI100,一个刚刚2岁的研究项目,但它的预设寿命是100年,甚至更长...

AlphaGo与李世石的人机大战,为大众迅速普及了人工智能的概念。 但对谷歌而言,除了下围棋,现在的人工智能进展到哪一步了?未来,人工智能...